Part 1
Getting Started

Welcome to the Virtual Tablet Interface! This manual describes how to the use the Interface to create
beautiful color templates for use with your digitizing tablet. You do not have to be an experienced
computer-user or programmer to create templates which can greatly simplify using your favorite
DOS and Windows applications.

Templates are graphical menus which are over-laid on the surface of your digitizer and respond to
commands simply by selecting an area of the tablet. This can greatly speed up certain applications
and free you from having to remember complex command sequences or complicated menu
structures. Studies have shown that templates can improve productivity by up to 400% depending on
the application and level of familiarity!

In the next four chapters, you will learn how to install the Interface, start and navigate the Virtual
Tablet Editor, and create templates for your favorite Windows applications in under one minute.
Whether you are looking for a quick way to create templates for your Windows applications or to
save hours building large complex templates, this section is for you.

Novice users will enjoy the ease in which templates for all their Windows applications can be

created with the simple click of a button. Experienced users will learn that the template building
basics described here can save many hours of effort on the way to large and complex templates.
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Chapter 1
Introduction

The Virtual Tablet Interface is a high performance digitizer interface designed for today's complex graphical
applications. Key features of the Virtual Tablet Interface include:

Drivers and Utilities
n A Windows dynamic link library, VTABLET.DLL, and an enhanced mode windows driver, VTABLET.386,
which provide an interface between the digitizer and Microsoft Windows supporting the following features:

mouse driver, Pen Windows driver, template execution and tracing objects from your digitizer.

n A DOS device driver, VTABLET.SYS, which provides an interface between the digitizer and DOS supporting
the following features: template execution and the Autodesk Device Interface.

n A template manager, VTLOAD.EXE, which can load and execute templates along with their applications using
either an iconic or command line interface.

Virtual Tablet Editor

n  Create or edit templates from scratch, using an automated template builder, or by tracing directly from existing
blueprints and graphical images;

n  "One-Minute Templates" which allow novice users to create color templates for any Windows application
simply by pointing and clicking on the application's window.

n Read and write a variety of graphics file formats including Windows Metafiles and Device Independent
Bitmaps.

n Import and export host-independent template modules for commonly used template functions facilitating the
exchange and standardization of template designs.

n Variety of output options allowing templates to be printed at reduced or actual size, or up to billboard size for
trade shows and advertisements.

n Integrated compiler for producing device and host-independent template command files.

n Standard computer-aided-design and Windows features including pan, zoom, multiple-selections and undo as
well as clipboard cut, copy and paste.

Using This Manual

This manual is divided into four parts: Getting Started, Creating Templates, Tools & Options, and Appendices. The first
part titled Getting Started which describes Editor basics and how to create templates in under one minute. Chapters in
this part, along with their contents, are as follows:

Introduction Interface features, information on using this manual and obtaining help.
Installation & Startup Installation, starting the Editor, screen layout and accessing files.
Navigation Aids How to change views, scrolling, mouse cursors, tablet guides, the status bar and

toolbar.
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One-Minute Templates How to create templates in under one minute including building, saving, compiling, printing
and executing templates.

The second part titled Creating Templates details each step for creating complex templates. Chapters in this part, along
with their contents, are as follows:

Tablet Properties How to change the digitizing tablet and system of measurement.

Creating Regions Drawing, selecting, stretching, moving, aligning, duplicating and removing regions.
Styles & Combinations How to apply styles and work with region combinations.

Importing & Exporting Importing and exporting graphics files and how to use Editor Export files.

Printing Printing templates including output formats, options and tips.

The third part titled Tools and Options explores the tools and options for building complex templates and configuring the
Editor. Chapters in this part, along with their contents, are as follows:

Using Tools How to compile templates, trace regions and execute templates.

Changing Options How to alter the program display, configure tablet guides, create file backups and add
comments to your template.

The Clipboard How to cut, copy, paste, view and undo using the Windows clipboard.

Finally, the Appendices provide a reference to the key codes, drivers and digitizers supported by the Virtual Tablet
Interface. Chapters in this part, along with their contents, are as follows:

Virtual Key Codes Virtual Key Codes used by the Virtual Tablet Interface utilities and drivers.
Windows Driver A dynamic-link library that provides the digitizer interface to Windows.
DOS Driver A DOS device driver that provides the digitizer interface to DOS.

Digitizers Supported A reference guide to supported digitizing devices.

Getting Help

On-line help is available from the Help menu or by pressing the F1 key anywhere within the Editor or Loader including
menus and dialog boxes. Help includes a detailed reference to each menu command, mouse cursor and keyboard
shortcut. Pressing the F1 key or choosing Contents from the Help menu displays the Windows Help utility.

The Help window has buttons to move around the Help system easily. If a feature is not available, the button associated
with it is dimmed. By choosing a button at the top of the Help window, you can display a list of Help topics, search for a
list of topics that include a particular keyword, and move forward and backward through the Help topics used in the
current help session.

Some words in a Help window are marked with a solid underline and appear in color if you have a color display. These

words are jump terms you can use to move around the Help system quickly. When you click on a jump term, you
immediately move to a Help topic associated with that word.
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You can get help about using the Help system's features by choosing How to Use Help from the Help menu or by
pressing the F1 key once inside the Help window.

Electronic Support

If you need technical assistance, you may send electronic mail to Digitizer Technology on CompuServe account [74000,
2506]. Please include a full description of the problem which will be responded to within one working day. This is the
fastest and preferred method of obtaining direct help from Digitizer Technology.

Telephone Support

If you need telephone assistance, you may call Digitizer Technology Monday - Friday at (206) 868-3246 between 8:00
AM and 10:00 PM, Pacific Standard Time. Please have a copy of your autoexec.bat, config.sys and win.ini files ready
along with information on the circumstances in which the problem occurred.

Mail Support

If you would like to mail your questions or comments to Digitizer Technology, we can be reached at: Digitizer
Technology Company, 16541 Redmond Way, Suite 195C, Redmond, WA 98052.
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Chapter 2
Installation and Startup

Installing the Interface

To install the Virtual Tablet Interface, first make sure make sure your computer and monitor are turned on and that
Microsoft Windows (including Pen Windows) is installed and running. If you have not installed and tested your
digitizing tablet, follow the directions provided by the manufacturer and do so now.

1 If Windows hasn't been started, type win at the DOS command prompt (C:\) and press ENTER.

2 If the Windows Program Manager is not active, double-click the Program Manager icon or hold down the CTRL
key while you press the ESCAPE key to display the Task List. Then, press the DOWN ARROW or UP ARROW keys
until the Program Manager is highlighted and press ENTER.

3 Insert the Virtual Tablet Interface disk in drive A; then, if necessary, close the disk drive door.

4  In the Program Manager window, choose Run from the File menu.

5 Inthe Command Line box type a:\setup.

6  Click the OK button or press ENTER.

7  Follow the instructions displayed on your screen.

When you've finished the setup, you should probably re-start your computer and Windows to make sure the device
drivers are installed correctly.

Starting the Editor

You may start the Editor either from Windows or the DOS. If you start the Editor from a command line, you may also
specify a template file which will loaded automatically and displayed for editing in the program window.

To specify a template file, follow the command name for the Editor with the file name optionally preceded with a drive
and path qualifier. If you do not specify a file name, or the file name is invalid, the Editor creates a new template titled
(Untitled). Editor files use the extension .VTE.

Starting from Windows

To start the Editor from Windows, double-click on the Editor icon in the Virtual Tablet group created in the Program
Manager when you installed the Virtual Tablet Interface. You can also start the Editor from a command line in the
Program Manager by selecting the Run command from the File menu. Finally, you can start the Editor and load a
template file by double-clicking on the template file name from within the File Manager or its icon from within the
Program Manager.

Starting from DOS

To start the Editor from DOS, first start Windows by typing win and then the Editor as described above. You may also
start Windows and the Editor together by typing win vtedit <filename>.

Screen Layout
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Each time you start the Editor, the program window appears on the desk-top with the template sized to fit within the
window's borders. An example of the Editor's window is shown below.
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Border The window border is used for changing the size of the program window. This is useful if you have
other applications running and need to size the Editor window to see them clearly.
Title Bar Besides identifying name of the program and template you are currently editing, the title bar also is
used to position the Editor on the Windows desk-top.
Menu Bar The menu bar contains sub-menus for each command supported by the Editor. These commands are
discussed in detail through out this manual and in the on-line help by sub-menu.
Tool Bar The tool bar contains miniature icons for commonly used commands. These commands are discussed
in detail through out this manual and in the on-line help by sub-menu.
Scroll Bars Scroll bars enable you to scroll a template either vertically or horizontally. They may be hidden or
shown by selecting Display from the Options menu.
Status Bar The status bar provides menu assistance and reports the cursor location, zoom level and display options
selected. It may be hidden or shown by selecting Display from the Options menu.
Client Area The client area is the area of the program's window where you interact with the graphical objects in
your template. These include: the active area, regions and combinations.
Active Area The active area is the actual area of the digitizer where drawing and interaction takes place. The size
depends on your digitizer, and is where regions and combinations are created.
Regions Regions are parts of the active area where interaction between the user and computer take place. They

may be defined as either Pen or Pointer regions for cursor movement or template regions which send command keys to
an application when a button is pressed within their border.
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Combos Combinations are regions linked together for stylistic or selection purposes. They perform no
interaction with the user and have no impact on template operation. However, they are useful for grouping common
template functions in a template.

Accessing Files

If you do not specify a template file when starting the Editor, a new one titled "Untitled" is automatically created for you.
You may also create a new template any time by selecting the New command from the File menu. If there are changes to
your template, you will be prompted to save them first.

Opening Files

To open an existing file, select the Open command from the File menu or press the F3 key. If there are changes to your
template, you will be prompted to save them first. You are then presented with the Open dialog box.

At the top of the dialog box are the words "File Name" followed by a field which allows you to type in the name of the

file, or a DOS file specification including the wild cards "*' and '?. If you are not familiar with DOS conventions for
specifying disk, directory and filenames, consult your DOS manual or Windows User's Guide.

File Hame: Directories:

* whe | ciwtivzamwtedit

Cancel

yviedit_vte

Another way to locate the file you wish to open is to change the current drive and directory by double-clicking on the
selections in the directories list box. As you change the drive or directory, the new path is displayed in the field below
"Directories:". Once you have found the file, either double-click on its name, or single-click to place it in the File Name
field and then click the open button or press ENTER. Editor files use the extension .VTE.

You may cancel opening a file at any time by clicking the Cancel button or pressing the ESCAPE key. Canceling the Open
dialog box leaves your original template unchanged.

Fast Files

Each time you save a template file, its name is added to the end of the File menu after the Exit command. To open a
recent file, simply choose its name from the File menu. If the file is not found, its name will be removed from the File
menu and a new template created. The Editor tracks the last four files saved which can also be opened by pressing the
ALT+F,1 or ALT+F,2 or ALT+F, 3 or ALT+F,4 key combinations for each of the last four files, respectively.

Exiting the Editor

To leave the Editor, choose Exit from the File menu or press ALT+F4. If there are any changes to your template, you will
be prompted to save them first. You may cancel exiting the Editor at this point and return to the program window, or
discard your changes and leave the Editor.
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Chapter 3
Navigation Aids

The Editor provides a variety of navigation aids to assist you in panning, zooming and viewing your template. Panning
refers to moving the visible portion of your template within the client area. Zooming refers to changing the scale of the
template as it appears within the client area. There are also several means of locating or placing objects using grids
within the active area.

Changing Views

You may change the zoom level of the template by selecting a command from the View menu. These commands allow
you to zoom in or out; fit the entire template, a selected portion or the current selection to the client area; zoom to actual
size; redraw the template; and restore the previous view.

Each time you change the view, the client area is redrawn and the Status Bar is updated to reflect the zoom level. The
Status Bar tracks cursor movement and zoom level and is discussed below.

Zoom Special

Q

The Zoom Special command allows you to zoom part of the active area to fit within the client area. When you select this
command or press CTRL+Z, the cursor changes to the Zoom Special cursor. Position the cursor outside the zoom area and
press the left mouse button. Holding down the left button, drag the cursor across the active area. A marquee rectangle
will be shown displaying the zoomed area.

When this rectangle encompasses the part you wish to zoom, release the left mouse button. The client area will be

redrawn with the area selected zoomed to fit within its borders. You may cancel the Zoom Special command by pressing
the ESCAPE key or choosing another menu command.

Using Scroll Bars

You can pan the template either up and down (vertical scroll bar) or left and right (horizontal scroll bar). Each time you
scroll one line-up or down, the template scrolls 1/20th of the current screen view. If you select the page-up or page-down
commands, the template scrolls one full screen distance.

You may show or hide each of the scroll bars by choosing Display from the Options menu or pressing the F8 key and

checking or unchecking the check box for each scroll bar. For more information, see the Display section in the chapter
titled Changing Options.

Keyboard Shortcuts

The following keyboard shortcuts can assist you in navigating the Editor's program window:

Shortcut Zoom or Scrolling Action

UP ARROW Scrolls the client area one line up.
DOWN ARROW Scrolls the client area one line down.
LEFT ARROW Scrolls the client area one line left.
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RIGHT ARROW Scrolls the client area one line right.

PAGE UP Scrolls the client area one page up.

PAGE DOWN Scrolls the client area one page down.

CTRL+PAGE UP Scrolls the client area one page left.

CTRL+PAGE DOWN Scrolls the client area one page right.

CTRL+T Zooms the template to fit within the client area.

CTRL+E Zooms the current selection to fit within the client area.
CTRL+I Increases the zoom level by one resulting in a larger view.
CTRL+O Decreases the zoom level by one resulting in a smaller view.
CTRL+U Sets the zoom level to one or a view of the actual size.
CTRL+L Restores the previous zoom level and template origin.
ESCAPE Cancels zoom special, trace mode and screen painting.

Mouse Cursors

The cursor takes on different shapes in the Editor depending on where it is in the program window and which command
is currently active. The following table shows the cursor shapes you see in various parts of the Editor and describes the
mouse action you use with each cursor shape:

Pointer
In menus, scroll bars, dialogs and the program window outside the active area. Used for pointing and selecting.

Crosshair
In the active area outside selection. Used for selecting regions and combinations.

Hourglass
Any area of the program window. Used for waiting for a command or action to be carried out.

E
b

Inside vertical drag handles of selection. Used for stretching selection vertically.

T

Inside horizontal drag handles of selection. Used for stretching selection horizontally.

Inside corner drag handles of selection. Used for stretching selection diagonally.

&

Inside of selection. Used for dragging selection in the active area.
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Q

In active area when Zoom Special command is active. Used for drawing the zoom selection.

o)

In active area when Trace command is active. Used for tracing regions from the digitizer.

Anywhere on the desk-top when Build command is active. Used for selecting a target window for the template builder.

Cursor Selections

The cursor is compatible with IBM's Common User Access and is frequently used to create or select regions and
combinations in the active area including following actions:

Click for Single Choice Selection: Clicking the left mouse button once without pressing any modifier keys, such as
CTRL, selects a single-choice but deselects all previously selected objects.

Single-Range Selection: There are two techniques for creating a single range of objects. Drag Select allows you to press
and hold the left mouse button while dragging the cursor across the active area. Shift Select is available using the SHIFT
key to establish the range from the previous selection.

CTRL Key for Multiple Range Selection: Pressing and holding the CTRL key while making selections does not

deselect the previous selections but simply adds or removes objects to the current selection. Any number of objects may
be selected in this manner.

Tablet Guides

Tablet guides provide a convenient way to locate and place objects within the active area. They consist of a tablet grid
which may be displayed and to which object coordinates may be snapped. To show or configure the tablet guides, select
Guides from the Options menu or press the F9 key.

Tool Bar

The Tool Bar appears below the Editor's menu bar and provides quick access to commonly used commands. These
commands from left to right on the toolbar (not all shown below) are as follows: New, Open, Save, Cut. Copy, Paste,
Undo, Zoom In, Zoom Out, Zoom Template, Zoom Special, Properties, Styles, Combine, Break Apart, Display, Guides,
Backups, Compile, Build, Trace, Execute and Help.

Dl=]2] (* =@ (& [+ [+ )e]3]) FEs)ele)

To show or hide the Tool Bar, choose Display from the Options menu or press the F8 key.

Status Bar

The Status Bar appears below the Editor's window and provides short help on menu commands, the X and Y location of
cursor in the active area, the current zoom level, object (tablet, combination or region) selected, and whether draft
quality, font greeking and metric measurements are in effect. To show or hide the Status Bar, choose Display from the
Options menu or press the F8 key.
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Chapter 4
One-Minute Templates

This chapter introduces one of the most powerful features of the Editor for novice and experienced users alike building
templates for any Windows application in under one minute! Templates that used to take months of dedicated effort by a
team of experienced programmers can now be created by the most casual user in no time at all.

Whether you are simply looking for a quick way to create templates for your Windows applications or interested in
saving hours building large, complex templates, this chapter is for you. Novice users will enjoy the ease in which
pleasing templates for all their Windows applications can be created with the simple click of a button. Experienced users
will quickly learn that the template building process described here can save many hours of effort on the way to large and
complex templates.

Building

To begin building templates, choose Build from the Tools menu or pressing the ALT+T,B keys. You will then be
presented with the Build dialog box shown below.

[ Apphcation

Mame: Mot S5elected
Class: Mot S5elected

 Menus

B s pstem Menu

2 Cascade Popups

$Epaifed
&4 Combine Popups

B Automatic Styles Cancel I

The first thing to do is select the Windows application for which you wish to build the template. For now, we'll build a
template for the Program Manager which is normally loaded when Windows starts. Later, when you create templates for
your other Windows applications, make sure they are loaded before selecting the Build command.

To select the Program Manager as the target application, click on the Select button in the Application section or press the
ALT+S keys. The cursor changes to the Build tool shown here. Using the cursor, position the Build tool over the Program
Manager's window or icon and press the left mouse button. The Build tool should disappear and the cursor change back
to a normal pointer.

If you miss the Program Manager and hit the Windows desktop by accident, you will get a warning message indicating
that no application was selected. Simply dismiss the message box by clicking the OK button or pressing ENTER. Then,
click on the Select button or press the ALT+S keys again to use the Build tool to select the right window. You may
continue selecting applications as many times as you wish until you are satisfied the right window has been selected.

After selecting the Program Manager, the Build dialog box is updated to display the Program Manager's filename and
window class in the fields labeled Name and Class. These fields should now be PROGMAN.EXE and PROGMAN,
respectively. If they are not, try selecting the Program Manager again.
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Build Options

The Menus section of the Build dialog provides options for building templates including which application menu items
are used, to what level of detail the build command will use the menus and the types of styles used for template regions.
Build options include:

System Menu Includes the Windows system menu, or the menu in the upper-left corner of each
window used for moving, sizing, closing and switching windows.

Cascade Menus Directs the template builder to descend into cascading menus, building new template
areas for each level encountered.

Combine Popups Directs the template builder to combine from regions assigned to each popup menu in the
target window.

Automatic Styles Allows the template builder to select its own styles and choice of colors for regions and
combinations versus the their default styles.

For now, just leave all these options in their default states. Later on, you can experiment with customizing the Build
command using these options for all your Windows applications.

After you select a target application, the Build button at the bottom of the dialog becomes enabled. If you have selected
the Program Manager's window and the rest of the dialog box options are correct, click on the Build button or press
ENTER now. The Build dialog box disappears and the cursor will change to an hourglass while the Build command does
its work.

If you are editing a template and have not saved it, you will then be prompted to save it first. If you answer Yes, the
template will be saved. Alternatively, if you answer No, then the template changes will be discarded. You may cancel
building the template by selecting the Cancel button.

After a few seconds, the Editor window will change as the new template is displayed in the client area and the name is
added to the Editor's title bar.

= ¥T Editor - Progman.vie nn
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You'll notice that a number of rectangular regions were created encompassing each Program Manager menu command
and that they are grouped together by each sub-menu. Each of these boxes is called a "template region" and the groups
called "combinations." The default options for the Build command creates these regions, groups them together and
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assigns a color to each group.

Saving Files

Chances are you'll want to return to this template again in order to edit and add enhancements. To do this, you must save
the template on your disk before exiting the Editor or Windows. Choose Save from the File menu or press the F5 key.

Your template will be saved in the current directory under the PROGMAN.VTE filename. Editor template files use the
extension .VTE.

If you wish to save the template under a different filename, choose Save As from the File menu or press the F5 key
instead. You will be presented with the Save As dialog box.

= SaveAs
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At the top of the Save As dialog box are the words "File Name" followed by a field indicating the current drive and
directory. If these are not correct, change the drive or directory along with the new file name.

You may also have the Editor create a Program Manager icon in the Virtual Tablet group by checking the box labeled
"Create Icon." Then, each time you wish to edit the template, double-click on its icon in the Virtual Tablet program
group.

Once you have completed the file specification, click the Save button or press ENTER to save the file under the new

name. The new name will appear in the Editor's title bar. To cancel saving the file, click on the Cancel button or press the
ESCAPE key.

Printing

The Editor provides a variety of options for printing your templates. To print the Program Manager's template, choose
Print command from the File menu or press the F7 key. The Print dialog box will be displayed.

™ Options

L] Draft Quality

_} Fit to Page
O As Displayed
> Tiling Guide
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] Crop Marks
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Output formats and options are discussed in the chapter on printing. For now, however, just make sure your dialog box
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matches the one shown. If not, change the output format to Actual Size and deselect any other Options using the mouse
or keyboard. Make sure your printer or plotter is selected from the Windows Control Panel and it is turned on and ready
to print. Then, click the Print button or press ENTER.

If everything goes correctly, a dialog box will be displayed which informs you of the status of the template printing and
gives you an opportunity to cancel at any time. To cancel printing, click the Cancel button or press the ESCAPE key. The
Editor will stop printing your template and return you to the program window. If you do not cancel printing, page
numbers and objects will be displayed as they are printed and the dialog closed when completed.

The quality and number of pages for your printed template will vary depending on: the size of your digitizer; type,
quality, size and page orientation of your printer or plotter; and the complexity of your template. The Editor supports
styles and output options for just about everybody and you'll have to experiment until you find the right combination for
your particular system.

Printing templates can involve enough variables that an entire chapter is devoted to it. The chapter on printing contains
many tips for improving your output, but here are a couple tips and tricks to get you started:

n  Use the highest quality and largest printer or plotter you have access to for your final output. If you do not have
the quality and size you wish, consider printing the template to a file and finding someone who does (like a
friend, another department or even a service bureau).

n  Set your page orientation to match your digitizer, i.e. portrait or landscape. This can make a big difference in the
number of pages printed and the effort needed to assemble a large template.

n  If your printer or plotter is smaller than your digitizer, include the Crop Marks option in the Print dialog box to
assist you in assembling your template from the printed output.

n If you use a plotter or dot-matrix printer, refrain from using imported graphics or complex templates since they
will not match the quality of your output device. This is particularly true for bitmaps and other raster images.

n  Use the Fit to Page option in the Print dialog box to proof your template. This saves paper and eliminates the
need to assemble large templates until you are ready for final output.

Finally, if you select Actual Size and your digitizer is larger than your printer (the case for most people who use standard
8 1/2 by 11 paper), your printed output will be tiled across several pages. These must be clipped (easier if your include
crop marks) and assembled to produce the template.

Compiling

Compilers translate human languages into instructions computers can understand. While they are generally used by
computer programmers, the compiler in the Editor is easy enough to use by anyone regardless of their computer
proficiency.

To compile your template, choose Compile command from the Tools menu or pressing the F11 key. The cursor will
change to an hourglass while the template is being compiled. After a few seconds, the cursor will change back to a
normal pointer and a message box displayed indicating the command file has been created.

Executing

Templates don't have much value unless your digitizer and computer know about them. To do this, you must load them
using the Virtual Tablet Loader which is included with the Virtual Tablet Interface. If you have not yet installed the
Virtual Tablet Loader, stop now and install it using the Setup utility provided on your diskettes.

To access the Virtual Tablet Loader from within the Editor, choose Execute command from the Tools menu or pressing
the F12 key. The Virtual Tablet Loader will be displayed on the Windows desktop and is used to create Virtual Tablet
Information (.VTI) files which can automatically load your Windows application and its template.
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For our example, we will create a Virtual Tablet Information file for the Program Manager using the template we just
created. First, click on the Select button in the Application section or choose Select from the Application menu. The
cursor will change to a bomb-sight just like the Build tool used with the Build command.

Using the cursor, position the bomb-sight over the Program Manager's window or icon and press the left mouse button.
The bomb-sight will disappear and the cursor change back to a normal pointer. If you miss the Program Manager, click
the Select button again to select the right window. You may continue selecting target windows until the right window has
been selected.

After selecting the Program Manager, the Loader dialog box will be updated to display the Program Manager's filename
and window class in the Application fields labeled Name and Class. These fields should now be PROGMAN.EXE and
PROGMAN, respectively. If they are not, try selecting the Program Manager window until they are correct.

You'll notice several other options in the Application section were enabled after selecting the Program Manger's window.
These include fields for controlling how a template interacts with the target window under certain conditions. For now,
just make sure they are all selected using either the mouse or keyboard. Refer to Executing Templates in the chapter
titled Using Tools to learn more about using these options.

After selecting the Program Manager, you must specify a template file. This is done through the Template section of the
Loader's dialog window and is nothing more than the familiar Open dialog box found in many Windows applications.
For now, click on the PROGMAN.VTT filename in the list box under the words "Files In". The File Name edit box should
change to reflect selected filename. If not, use the list box to change the drive or path until the PROGMAN.VTT filename
can be selected.

After you have selected the PROGMAN.VTT file, click the Open button or select the Open File command from the
Template menu by pulling it down or pressing the ALT+T,P keys. If there are no file errors, the Open button should
become disabled, and the Close and Info buttons enabled.

To save the Program Manager configuration and its associated template in a Virtual Tablet Information file, choose the
Save command from the File menu or press the CTRL+S keys. Since this is a new file, you will be presented with the Save
As dialog box.

Enter a filename and click the Save button or press ENTER. The file will be saved on disk and can be used to load both

the Program Manger and its template file automatically each time you start Windows. If you change your mind, click the
Cancel button or press the ESCAPE key. Virtual Tablet Information files use the extension .VTI.
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You may have the Virtual Tablet Loader create a Program Manager icon in the Virtual Tablet group by checking the box
labeled "Create Icon." Then, each time you wish to start both a template and its application, double-click on its icon in
the Virtual Tablet program group.

It's time to tell the Virtual Tablet Loader to accept your changes and put them into action. Before doing this, make sure
your digitizer is turned on and ready to go. Then, click the OK button or press ENTER. The Loader will minimize itself to
an icon and the template will become activated.

If you specified the Windows Driver VTABLET.DLL as the mouse pointer during installation, or you are running
Windows Version 3.1 or later, the mouse pointer will respond when moved within the template area titled Display. If not,
you can continue using whatever Windows pointing device you have to move the cursor.

Test the Program Manager template now by activating and maximizing the Program Manager window. Then, try pressing
and releasing button one on the digitizer when positioned over any of the template regions. The Program Manger's menu
should flash as the command is executed. Try this for each command to make sure the template is working correctly.

If you experience problems with the Program Manager template, maximize the Virtual Tablet Loader and check all the
options, particularly the Application information and template filename. If you still cannot get the template to work,
check to make sure your digitizer is turned on and connected correctly to your computer. Also, make sure
VTABLET.DLL is installed and that the Program Manager window is active and maximized, i.e. non-iconic. Finally,
review all the steps covered in this chapter to make sure you did not miss anything.

To quit using the Program Manager template, select the Virtual Tablet Loader again and maximize it. Click on the Close
button in the Templates section or choose Close from the Template menu. Then, click the OK button or press ENTER and
the Program Manager template will become disabled. You may then select a new template and target window or open an
existing Virtual Tablet Information file.

To exit the Loader, choose Exit from the File menu or press the ALT+F4 keys. If there are any changes to the Virtual
Tablet Information file, you will be prompted to save them first.
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